Project 2010 and Project Server 2010: The Beta is out – some early issues people are seeing

If this is the first you have heard of the Beta (Where have you been?  Can I come next time?) then take a look at http://blogs.msdn.com/project/archive/2009/11/18/now-available-project-2010-beta.aspx for the links to Project and http://blogs.msdn.com/project_programmability/archive/2009/11/19/project-2010-sdk.aspx for great links to the new developer stuff (Great work Jim!).

A couple of early issues or regular questions are:

  • Can I use Project Professional 2010 against a 2007 server?

No, 2010 can only talk to 2010 Server.  You can however still use 2007 against an upgraded (2007 to 2010) Project Server instance as long as it is still set for Backwards Compatibility Mode.  Once you switch to native mode you cannot switch back1  Another option available to you is installing 2007 and 2010 side by side (but not running both at the same time).  If you have any connectivity issues then usually running a repair on the 2007 Project Professional will resolve this.  Be aware that opening Projects from PWA will likely give you issues, as the wrong Pro may try and start.

  • I get an unexpected error from SharePoint Foundation after provisioning my first PWA site.

This one relates to a bug which we thought we had addressed in the documentation, but it came back to bite us. The docs are being updated as I write, but in case you already ran in to this you can remove your provisioned PWA and the associated databases, carry out these steps:

  1. Open a command prompt as an Administrator.
  2. Navigate to program filescommon filesmicrosoft sharedweb server extensions14bin.
  3. Run the following command:
    • psconfig -cmd upgrade -inplace b2b

and then provisioning PWA should work just fine.  This issue will also give errors in various places – the event log will show a compatibility issue with the published database, the queue will not start, and then a couple of new pages in Central Admin will also get alarm bells ringing:

 

clip_image002

clip_image002[6]

The key things here are “Upgrade Required” against the server, and “Database is too old and upgrade is required” against each of the ProjectServer databases.