Project Server 2013 and Project Online: What happened to my resources?

*** Update 2/16/2015 – This fix has been in every CU and PU since April 2014 – so please patch rather than using the KB.  The final fix in the April 2014 CU and newer was slightly different in implementation that the stored procedure change shown in the KB – so do not be alarmed if you see that your DB has slightly different sprocs than listed in the KB.  Some additional where clauses were added in the final fix, but the KB did do the job of making sure the resource deletions stopped.  ***

*** Update 2/13 – please also see Knowledgebase article – http://support.microsoft.com/kb/2933444 for published details on this issue – including a detection script and a SQL command to correct a stored procedure to avoid this problem – only applicable to Project Server 2013 – Project Online is already patched ***

We have been working on this Project Server 2013 and Project Online ‘Lost Resources’ bug for a little while and we finally have it nailed, and already have the fix deployed to Project Online to ensure it cannot have any further effect there.  Now we wanted to share more information – as we have something actionable.  The scenario is that you open a plan and find that your resources appear to be gone.  Depends where you look, but you either see them as apparent material resources in the resource sheet – with no name, or in the Gantt you see numbers where you expected to see names – and similarly they are material resources in the resource form.  So imagine your plan looked like this:

Original Plan

You could open the plan and you find it is looking like this instead – with the resources missing. In this case two look like material resources – just one remains.  The numbers (8) in this case is coming from the hours of work.

Missing Resources showing with numbers instead

The resource sheet will look like this:

Missing resources blank

There are some variations on this theme – if all resources are removed from a task – or if you carry on using the plan, and try to add the resources back through build team, or publish the plan – then the symptoms can change and the resources can show as multiple <unassigned resource> placeholders – so best if you see the original issue to just close and don’t save – and follow the advice below.  The unassigned resource condition looks like the following.

Unassigned Resources

If you experience this then we can certainly help you if you open a support incident.  We do not charge for support incidents that are bugs – so you will either be refunded if you open a fixed cost incident, or you will not be decremented if this is a Premier incident.  Use your normal channels, either Premier or any of the options at http://support.microsoft.com – or in Project Online get one of your Project Online/Office 365 administrators to go to the Office 365 Admin Center, click the Support link in the left navigation (https://portal.microsoftonline.com/Support/SupportOverview.aspx) and then click new service request – middle right on the page. 

In Project Server 2013 the easiest recovery is to just restore from the administrative backup (the timing of my recent reminder to make sure it was running was not an accident – Project Server 2013- Check your administrative backups before you need them). 

For Project Online one option is to open from the Published store – and then overwrite the working store – assuming you haven’t published.  If you are time tracking then this isn’t a good idea as GUIDs change and assignments won’t match the current timesheet.  We can help with the recovery if you open an incident.

The good news is that we have a fix to stop this happening again which, as I mentioned, we have already applied to all our Project Online customers.  As with most fixes, this addresses the original problem but does not correct the downstream issues.  Due to the nature of the issue we can address some of this correction in the database.  For on-premises customers we are pushing hard to get this into the next available fix package – but it will certainly be in the April Cumulative update for Project Server 2013.  And we are able to assist any customers who open an incident with the means to stop this happening again right now.

There could be some variations in the steps that lead to this issue – but in basic terms saving a plan over another plan after having removed some resources may also remove those resources from other plans they are assigned in.  It takes them out of the team – but their assignments still  exist.  One scenario, and the one used to produce the screenshots above was to create an enterprise project plan that included some of the resources in the plan (Project1), then use save-as to overwrite another server plan that also includes those resources (Project2).  You will then find that the removed resources are also removed from other plan too (Project1 in this example).

So to summarize:

  • If you are running Project Online and see this issue open an incident (even though we have fixed Project Online the issue may still be in plans you haven’t even opened).  If you are not time-tracking then opening a copy from the published store may get you back where you need to be
  • If you are running Project Server 2013 then you should stop using save-as back to the server from Project Professional 2013 (or Project Pro for Office 356) until you have the fix (open an incident and we can get it to you).  We will update this post when we know if we can beat the April CU release – but it will certainly be in the April 2014 Cumulative Update for Project Server 2013
  • Quickest recovery for Project Server 2013 customers already affected by this is to restore all the affected plans from an administrative backup
  • If you haven’t seen the issue yet – you can still open a support incident to get the fix earlier than the April CU if you are concerned about this scenario

Some people may remember a similar sounding issue with 2010 – but this isn’t the same thing or same root cause.  This wasn’t and isn’t a problem that could occur in 2007 or 2010.  Also this was in Project Server 2013 and Project Online since the release – so don’t be afraid to apply cumulative updates – this wasn’t introduced by any of them.

If you have hit this issue then we are very sorry for the inconvenience and frustration that bugs like this can cause – we have been pushing hard to both get this fixed and make sure we can assist with any clean-up that you need.